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20 October 2017

Fathaha Khanam
Water Resources Modeller
Murray-Darling Basin Authority
GPO Box 1801 Canberra ACT 2601
Dear Fathaha,

Flexible mesh Development for Gunbower Koondrook Perricoota Forests
This report documents the first stages of development of a 1D-2D model of the Gunbower Koondrook
Perricoota (GKP) Forests, using flexible mesh and GPU Technology. Water Technology has setup a functional
MIKE FLOOD flexible mesh model in close collaboration with MDBA. This report describes step-by-step the
different processes to build the new model from the two existing models of the forests either side of the Murray
River.
The model files have been transferred to MDBA to further develop the model and complete the calibration.

Yours sincerely

Sebastien Barriere
Project Engineer
Sebastien.Barriere@watertech.com.au
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WATER TECHNOLOGY PTY LTD
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1

INTRODUCTION

In 2003 the Living Murray initiative identified the Gunbower-Koondrook-Perricoota floodplain system as one of
6 “icon sites,” recognising the floodplain system as a key ecological asset of the River Murray. The location of
each of the icon sites is shown inFigure 1-1. The Living Murray icon sites are considered a high priority for
conservation and rehabilitation.

Figure 1-1

The living Murray Icon sites; 2 – Gunbower, Koondrook-Pericoota Forests (Source: MDBA website)
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Gunbower Forest is a floodplain ecosystem reliant on flooding to maintain its ecological health. It is bounded
by the River Murray to the north and Gunbower Creek to the south, with a number of watercourses and
wetlands dispersed across the forest ranging from permanent to ephemeral. Many of the watercourses that
provide flow into the forest from the River Murray and Gunbower Creek are regulated.
Koondrook–Perricoota Forest is located on the NSW side of the River Murray, adjacent to Gunbower Forest.
In large natural flood events a large proportion of the River Murray flow enters the forest, flowing to the north
and west.
Torrumbarry Weir is situated on the Murray River close to the upstream end of the Gunbower KoondrookPerricoota Forests. The weir regulates the river flow to service a large irrigation district.
Regular floods of various sizes are required to maintain healthy and functioning ecological communities in the
Gunbower Koondrook–Perricoota Forests. Regulation of the River Murray has resulted in a reduction in the
magnitude, frequency and duration of natural floods. To enhance environmental outcomes, a range of
environmental infrastructure has been constructed within the forests.
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2

BACKGROUND

Numerous studies and investigations have been undertaken in the area, this results in a wealth of available
data and existing numerical tools.
Currently MDBA uses two distinct hydraulic models covering the Gunbower Forest and the KoondrookPerricoota Forest separately.
With the advance in computing capabilities and improvements to the available software, MDBA has
commissioned Water Technology to assist in the development of a numerical model that covers both floodplain
sites on either side of the River Murray.

5151-01_R01v01f_GKP_FM.docx

Figure 2-1

Gunbower model

Figure 2-2

Koondrook Perricoota Model

The objective of this project is to convert the existing two separate models to a single MIKE FLOOD flexible
mesh model, to allow for better resolution across the model domain in areas of interest. The revised model
schematisation therefore focuses primarily on changes to the 2D model representation, however other
improvements (i.e. to the 1D network and linking of the 1D/2D domains) are also made.
MIKE FLOOD 2017 allows for the coupling of a 2D flexible mesh domain with a 1D network. Simulations utilise
parallelized calculations via the Graphics Processing Unit (GPU) for the 2D component and the Central
Processing Unit (CPU) for the 1D component. This parallel solution technique results in increased calculation
speed, allowing for higher precision (greater resolution) without drastically increasing simulation times.
This document details, step-by-step, the process of developing the new combined model of the Gunbower
Koondrook-Perricoota Forests (referred to as GKP here-after).
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3

STEP BY STEP MODEL DEVELOPMENT

As requested by the MDBA, the development of the new model is described in detail in this document. It is a
step-by-step manual, of which sections were intermediately sent to MDBA to aid in the development of the
model, which was developed by Water Technology and MDA concurrently.

3.1

Digital elevation models and survey

A number of topographic and structural survey data sets used in previous investigations were available.
Several new datasets are now also available. These are detailed below.

3.1.1

LiDAR

The major dataset used to develop the 2D component of the model was a LiDAR data-set provided by the
MDBA. The dataset covered the full study area and had a grid resolution of 1 m.
LiDAR was used to interpolate the model topographic data applied to the elements of the flexible mesh. The
first step was to convert the dataset to a format compatible with the Mesh Generator tool (*.xyz or *.dfs2
format).
The objective is to convert the LiDAR from a raster to a *.dfs2 format.


Export the LiDAR raster to an Ascii file using a GIS software tool (to reduce the size of the file, resampling
and exporting a 2m grid is recommended);



Convert the Ascii file to a *.dfs2 using the MikeZero Toolbox


Open MIKE Zero : MZ Toolbox → GIS → Grd2Mike



Follow the dialogue prompts
Select the Ascii file:

5151-01_R01v01f_GKP_FM.docx
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Specify the projection to match that of the input data:



Specify the output file name and execute the tool. A pop up message should appear, indicating
that a file has been created.

Open the *.dfs2 that has been created and edit the properties of the following items :


name,



type (=bathymetry) and,



delete value = 999 (or any value larger than the maximum elevation in the file)

Save the file.

This grid is now ready to be used to interpolate the topography on the mesh elements.
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3.1.2

Feature survey data

Survey data containing waterway cross sections, levee profiles and crest heights as well as hydraulic
structures were compiled during past investigations. All the data available in the existing models was
maintained and imported into the new model. Details for specific structures are given in the following sections
of this document.

3.2

1D component

Several models in the area have been developed in the past, focusing on either side of the Murray River with
the Gunbower Forest on the Victorian side and the Koondrook-Perricoota Forests across the border to New
South Wales.
The current 1D models are constructed with MIKE11. It should be noted that DHI have replaced MIKE11 with
MIKE HYDRO in the recent software versions. In order to benefit from the latest developments of the software,
as well as support from DHI for technical issues in the future, the new model was implemented using MIKE
HYDRO. Conversion tools allow easy conversion from MIKE11 to MIKE HYDRO format. The figure below
illustrates the process used to create the first version of the combined 1D model of the GKP forests.
MIKE 11 geometry
files
• Export/import
branches
• Combine cross
section files

MIKE 11 "GKP"
model
• A single network
• Verify branch
connections and
boundaries

Convert to MIKE
HYDRO
• Update structure
definitons
(control and
regulation)

The following sections describe the set-up of all existing data into a single “GKP” model.

3.2.1

Branches and cross sections

In order to create the new model covering the entire area of the Gunbower and Koondrook-Perricoota forests,
the first step is to create a combined 1D network from all existing models. It is necessary to import all 1D
branches into a new single network, keeping the same naming (branch and TOPO ID) and chainage definition
to ensure all cross sections are correctly located along the waterways.
The easiest approach is to export the network branches from one model to a shapefile, and import the latter
to create the missing branches in the other model. The tools for this are found in the network editor (*.nwk11),
shown in Figure 3-1.

5151-01_R01v01f_GKP_FM.docx

It was decided to include Gunbower Creek in the 1D hydraulic model to allow the transfer of flows to key
delivery points along the creek, however this branch will not be laterally linked to the floodplain as the interest
is in managed flows along the creek that are within bank.
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Figure 3-1

Export branches to shapefiles and generate branches within the network editor (*.nwk11)

5151-01_R01v01f_GKP_FM.docx

The process of exporting the branches from the Koondrook-Perricoota model and generating the branches
from those shapefiles within the new network based on the Gunbower model, should yield a network with the
following characteristics:


54 branches



14 weirs



1 culvert



1 regulating structure



9 control structures

The addition of structures can be done manually in the network editor (MIKE11) or imported automatically from
a shapefile using MIKE HYDRO, given the necessary attributes exist (structure ID, type and branch name).
Water Technology chose to manually add the structures in the network file in MIKE11 before converting the
model to MIKE HYDRO. It should be noted that regulating structures are not supported in the conversion tool
to MIKE HYDRO. Furthermore, the approach to control/regulating structures has changed slightly from
MIKE11. A specific section will describe in detail the set-up of the regulating structure located on the right bank
of the Murray River, at the chainage 167000m approximately (MRC reg).
Figure 3-2 shows the different networks from existing models that are combined to create the single GKP
model.
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Figure 3-2

1D networks from existing hydraulic models
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Once the necessary branches have been imported into the new network, connections between branches and
subsequent open boundaries must be defined in the network and boundary files respectively.
Cross sections can easily be exported and imported from one cross section editor (*.xns11 file) to another
following these steps:


File > Export All Section or Export Selected Sections > Export Raw Data

5151-01_R01v01f_GKP_FM.docx



Select the cross sections to be exported in the cross-section editor (right click river name > select all
or double clicking specific cross sections)



Exporting cross sections creates a text file that can be imported in another *.xns11 file



Open the cross-section editor in which the data will be imported.


File > Import > Import raw data & recompute



The cross sections should now appear in the list
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3.2.2

Converting MIKE 11 to MIKE HYDRO

The conversion of a MIKE 11 set-up to MIKE HYDRO is straightforward and is described in the following steps:


Open a new MIKE HYDRO file

5151-01_R01v01f_GKP_FM.docx



MikeZero > new > MIKE HYDRO > MIKE HYDRO Model



In MIKE HYDRO : File > Import > Import from MIKE 11 > Simulation File and all […]



All elements of the set-up should be imported into the *.mhydro file except for the cross section file. The
cross sections remain stored in a separate *.xns11 file.
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After the import, MIKE HYDRO connects to the existing xns11 file. To ensure no data is lost or
overwritten by mistake, it is advised to create a copy of the cross-section data and connect to the
latter in the MIKE HYDRO simulation file.

5151-01_R01v01f_GKP_FM.docx

The map should show the following layout:



A number a background layers (DEM, images or shapefiles) can be added, provided they are in the same
projection.
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3.2.3

Control structures

A number of hydraulic structures are regulated to control the flows in and out of the Murray River and its
tributaries.
Control structures are used whenever the flow through a structure is to be regulated by the operation of a
movable gate (e.g. sluice gate, overflow gate, underflow gate, radial gate) or the flow is controlled directly as
in the case of a pump or a turbine.


Control structures in MIKE HYDRO River are defined through a CONTROL STRATEGY



The control strategy is the sequence of CONTROL RULES that determine the way a structure can be
operated in MIKE HYDRO River



A structure can have any number of strategies, defined by a sequence of conditional statements evaluated
as TRUE or FALSE during simulation

During the conversion from MIKE11 to MIKE HYDRO the control structures should have been recreated except
for the “Regulating” structure for the MRC regulator located on the branch named “Return”. This structure will
have to be redefined in MIKE HYDRO.
The key components in defining a control structure in MIKE HYDRO are the sensor, control object and the
control rules. The control strategy follows a logical decision tree based on the list of prioritised conditions, at
each time step the conditions are evaluated one after the other. If a condition is true then the action is
performed.

Sensor

Control object

Control rules

A sensor is a time-varying
variable used as a
parameter for a control
rule.
A sensor refers to an
object or location in the
river system used for
control.
A sensor may be a result
of a variable during
simulation, or an external
item read in a time series
(e.g. observed data)

The object/structure
that are to be controlled
and operated during
simulation.

Control strategies.
Conditional expressions
applied following a logical
decision tree.
Each control rule require
the definition of One or
more Conditions, and an
Action
• The Condition is one or
more criteria that must be
fulfilled for the control
rule to be executed, and
• The Action performed by
the structure when the
condition is evaluated to
“true”.

There are currently 9 control structures defined in the model:

5151-01_R01v01f_GKP_FM.docx





6 gates (4 underflow and 2 overflow structures)


Yarren Creek (chainage 30m and 5290m)



Murray River (Torrumbarry)



Hipwell dummy structure



Barhamcut Creek (“New central Bays” and “New Sidebays” at ch. 35.5m)

3 direct discharge


Cutting



Gunbower Creek (“National Channel” at ch.100m and another at ch. 18950m)
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The “Return MRC” structures in the existing MIKE 11 model defines a discharge flowing back to the Murray
based on a Q-H relationship. The levels conditioning the flow calculation are those arriving in the channel from
the floodplain.
The tabulated relationship between water levels and discharge has been extracted from the existing 1D model.
The structure is defined as “Direct discharge”.
Branch: “RETURN” and Chainage : 396m



The control strategy will be a direct application of the Q-H curve.
To implement the control strategy it is necessary to define the channel outlet (floodplain end) as a sensor.
Branch “RETURN” and Chainage: 0m



5151-01_R01v01f_GKP_FM.docx

The simple control rule is defined as follows:


If the water level at the channel entry is zero then do nothing



If there is water, the discharge applied must follow the tabulated values defined in the Action
section

Figure 3-3
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3.3

Preliminary Mesh creation

The generation of a flexible mesh is an iterative process. This section describes the first iteration of the mesh
generation for the 2D component of the GKP model.
Create workspace in
new Mesh Generator
*.mdf

Digitize/import model boundaries
Import the
topographic
data/scatter points
Generate a first ”rough” mesh and
export it

Setup a MIKE FLOOD
model and define links
between M11 and M21
FM

Start the MIKE FLOOD simulation
and create the "link data" that will
be used to refine mesh

Once the model has initialised and the “link data” has been created, the mesh can be refined in the *.mdf using
the river data from the 1D component.

Import the created file
river_curve.xyz file as
boundaries in the Mesh
Generator

5151-01_R01v01f_GKP_FM.docx

Run the coupled
simulation and analyse
the results

Further iterations

Generate and smooth
the mesh. Interpolate
the topography and
export it

Edit the mesh and
refine the mesh

Digitize the main
structures (levee,
roads, etc...)

Create polygons of
higher resolution (flood
runners in 2D for
example)

Figure 3-4
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The following section details the process described in the Figure 3-4, leading to the export of a “rough” mesh,
serving as a dummy for the creation of “link data”. Used subsequently to refine the mesh based on the 1D river
model.

3.3.1

Model boundaries (extent)

As shown in the figure above, the first step is to create a rough mesh that will be used to export the link data
between the 1D branches and the floodplain from MIKE FLOOD.


Create a new Mesh Generator file and import the LiDAR data created earlier (dfs2 file). The DEM will
serve two purposes. Firstly as a background layer showing the topography, and secondly this DEM will
be used to interpolate and append elevation values to the nodes of the mesh.




Data > Manage scatter data > Add (remember to display the data, it can take some time if the file is
big and click Apply). Will need to resample the 1 m resolution LiDAR to a lower resolution.

Digitize the boundaries of the model around the extent of the LIDAR. Drawing a closed polygon defines
the outer limits of the mesh that will be created. Ensure polygon is within the limits of the DEM.


import the boundary from an existing file (*.xyz created from a shapefile for example)

5151-01_R01v01f_GKP_FM.docx



Use the “Create arcs” tool and draw a closed polygon; or
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Generate a mesh with large elements (150,000 m2 for example). This will create a triangular mesh within
the limits defined by the polygons previously defined. The maximum element area defined in the pop-up
menu is the biggest area an element can be, hence this value controls the number of elements triangulated
during the mesh generation. The smaller the value, the higher the number of elements. The mesh
generator aims at triangulating the biggest allowable elements within the boundary. The smallest allowable
angle controls the shape of the triangles generated. Theoretically, the perfect mesh is composed of
equilateral triangles only. However, this isn’t practical because it would lead to very small elements. A
smaller angle generates bigger elements but with acute angles, which can create instabilities during
simulations. Usually, a good compromise is to use a smallest allowable angle between 26 and 30°

5151-01_R01v01f_GKP_FM.docx





Mesh > Generate mesh

Once the mesh has been generated (reminder that this is the preliminary mesh, other steps are required
prior to interpolation when creating a mesh but will be described in section 3.4) interpolate the topography
on the mesh in order to append elevation values to the nodes.
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Mesh > Interpolate (remember to select “Set value from scatter data”, this option reduces the
interpolation time considerably)

When the interpolation has completed remember to export the mesh to a *.mesh file :
Mesh > Export Mesh > select type: Mesh File

3.3.2

MIKE FLOOD : preliminary 1D/2D linking

Once the preliminary mesh has been exported, we can now create the 2D model set-up that will be linked to
the 1D model via MIKE FLOOD.
Import the mesh (*.mesh file) into a new *.m21fm file and complete all the necessary information to allow the
model to run independently (2D only).
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The same must be done for the 1D component, where the model should run (at least start, they do not have
to successfully complete the simulation at this stage) independently prior to linking it to the 2D model in MIKE
FLOOD. Once both models can initialize we can link them through the coupling software.
More technical details on the coupling between the models is given in section 3.5.
In MIKE FLOOD, there is an automatic tool that allows to define different types of links. We will be using the
lateral and standard links.


In the link definition tab, right click the graphical window and select the option “Link River Branch to
MIKE21”



Select the type of link to define and complete the necessary information to define the link, as shown in
Figure 3-5.



The following links were created:

5151-01_R01v01f_GKP_FM.docx

Table 3-1

List of MIKE FLOOD links

Type

Branch name

Lateral

MURRAY_RV_ds

63330

82020

Left

Lateral

MURRAY_RV_ds

61488

82020

Right

Lateral

MURRAY_RV_ds

82039

179859

Left

Lateral

MURRAY_RV_ds

82039

179859

Right

Lateral

DEEP_CK

0

2971

Left

Lateral

DEEP_CK

0

2971

Right

Lateral

SPUR_CK

5

14656

Left

Lateral

SPUR_CK

5

14656

Right

Lateral

BROKENAXLE_CK

40

6487

Left

Lateral

BROKENAXLE_CK

40

6487

Right

Lateral

LEITCHVILLE_CK

62

3356

Left

Lateral

LEITCHVILLE_CK

62

3356

Right

Lateral

YARREN_CK

35

5370

Left

Lateral

YARREN_CK

35

5370

Right

Lateral

CUTTING

222

3852

Left

Lateral

CUTTING

222

3852

Right

Lateral

Swan_us

626

2680

Left

Lateral

Swan_us

626

2680

Right

Lateral

Swan_ds

690

2001

Left

Lateral

Swan_ds

690

2001

Right

Lateral

Swan_lagoon_us_out

0

3747

Left

Lateral

Swan_lagoon_us_out

0

3747

Right

Lateral

Swan_lagoon_ds_out

0

2438

Left

Lateral

Swan_lagoon_ds_out

0

2438

Right

Lateral

Connector

0

920

Left

Lateral

Connector

0

920

Right

Lateral

SWANLAGOON_OUTLET

14

310

Left

Lateral

SWANLAGOON_OUTLET

14

310

Right
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Lateral

BARBERS

1239

3441

Left

Lateral

BARBERS

1239

3441

Right

Lateral

THULE

35

1184

Left

Lateral

THULE

35

1184

Right

Lateral

CameronCk

0

4085

Left

Lateral

CameronCk

0

4085

Right

Lateral

BARBERS_OFLOW

18

585

Left

Lateral

BARBERS_OFLOW

18

585

Right

Standard

CALF

16

Standard

COW

2040

Standard

THULE

Standard

CUTTING

3852

Standard

Swan_lagoon_ds_out

2438

Standard

Swan_lagoon_us_out

3747

Standard

SPUR_CK

14656

Standard

BARBERS

1239

Standard

CameronCk

4085

Standard

Gunbower_Rtns_us

6

Standard

Gunbower_Returns

206

Standard

Gbw_Return_ds

146

Standard

WATTLES_CK

209

Standard

BARHAMCUT_CK

520

Standard

RETURN

Standard

OFFTAKE_156333S

Standard

BARTONSWAMP_CK

Standard

THULE_CK

155

Standard

OFFTAKE_137476N

172

Standard

OFFTAKE_129806N

65

Standard

OFFTAKE_117518S

425

Standard

DeadRiver_outlet

1208

Standard

OFFTAKE_109221N

126

Standard

OFFTAKE_120899N

125

Standard

OFFTAKE_128106S

234

Standard

WATTLES_LAGOON

10

35

0
610
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43
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Figure 3-5

Linking in MIKE FLOOD (lateral and standard links)

The lateral links are defined by polylines that will be imported to the mesh generator. These polylines will act
as forcing lines and represent the banks of the river in the mesh.

5151-01_R01v01f_GKP_FM.docx

It is generally recommended to exclude the river channel which is modelled in MIKE HYDRO from the mesh.
In this way you avoid double conveyance in the river channel and you can include the link lines directly in the
mesh which will improve the flow across links.
Each point of the polyline will be a vertice along an arc once imported in the mesh generator. Hence, in order
to avoid small elements in the mesh, it is necessary to “clean” the polylines in MIKE FLOOD as much as
possible before exporting the link lines. More editing is possible in the Mesh Generator so the “cleaning” here
does not necessarily need to be perfect.
The objective here is to have the maximum distance between vertices while preserving as much as possible
the shape of the line representing the river banks.


Highlight the link by selecting the corresponding row in the link Definition tab,



When the link is selected, a toolbar should appear allowing to delete, move and add points



Delete, move or add points along the link as required and save the *.couple file
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Figure 3-6

Cleaning the lateral link polylines

To help you include link lines in the mesh, you can generate a text file from a MIKE FLOOD setup, which will
contain the coordinates of the linkage lines. This file lists all points along links and can be imported as boundary
in the Mesh Generator to generate a detailed mesh


Before you launch the simulation; open your *.m21fm file in a text editor, and search for the following
section:
[STRUCTURES]
[RIVER_LINKS]
type_of_coupling = 2
line_information = 2
output_of_link_data = 0
file_name_curve = 'river_curve.xyz'
file_name_section = 'river_section.xyz'
EndSect // RIVER_LINKS

Set the ‘output_of_link_data’ option to 3 instead of 0, and save the *.m21fm file.

You are ready to start the intermediate MIKE FLOOD simulation. During the pre-processing step, the
program will export all link coordinates to the river_curve.xyz and river_section.xyz files located in a subfolder containing result files from MIKE 21 FM. You don’t need to run the entire simulation and can stop it
after a few time steps.



Before you continue, open and verify that *.xyz files were created during the pre-processing step.
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3.4

Mesh refinement

The compromise between run-time and model resolution is key to the model development. The 2D mesh can
be supplemented with detailed linear features representing roads, channel banks and levees.
The mesh is developed by digitizing essential hydraulic and topographical features by way of polylines and/or
polygons, such as waterways, channels, roads and levees that will dictate the triangulation of elements within
the domain. Mesh resolution parameters (e.g. maximum cell size) are also defined for specified areas, thereby
enforcing finer elements where needed to represent smaller drainage lines and connections between wetlands.
In section 3.3 a preliminary (coarse) mesh was created to simply start a MIKE FLOOD model and export the
1D/2D lateral links. In the following section, the mesh will be refined as more detail will be incorporated aiming
to create the optimal mesh in terms of resolution and run time.

3.4.1 Use the created text files to generate a mesh that excludes the river
channels and includes link lines

5151-01_R01v01f_GKP_FM.docx

This section describes the step of importing the river banks represented by the lateral links created in MIKE
FLOOD. Importing these polylines allows to exclude the rivers from the 2D domain and only be accounted for
in the 1D model. Using the link polylines as arcs in the mesh also ensures the mesh is properly defined along
the watercourse and improves the flow calculations between the two models both in terms of accuracy and
stability.


Open the Mesh Generator file created previously and rename it.



Delete the existing mesh : Mesh > Delete Mesh.



To import the new *.xyz files as boundaries go to menu Data > Import Boundary. Browse for your files and
verify the information before you click [OK].


Column sequence : check by clicking “Data Info” > select X, Y, Z and Connectivity



Select the appropriate projection: GDA_1994_MGA_Zone_55



Select “Use connectivity information”



26 arcs should be imported

Murray-Darling Basin Authority | October 2017
Flexible Mesh Model Development

Page 26

5151-01_R01v01f_GKP_FM.docx

Figure 3-7



Mesh “arcs editing” after import of river links

From the imported arcs you need to generate polygons representing the river branches that will be
excluded from the mesh. Look at the distribution of the different vertices along the arcs and make sure
that they are relatively evenly distributed. Avoid for example very close vertices as they will force very
small elements in the mesh. You may also need to add arcs, modify, move or delete nodes and vertices.
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You should spend some time working on this step as the output mesh is very important. An example is
shown in the image below.


5151-01_R01v01f_GKP_FM.docx





If it makes it easier to work with, you can remove the display of the scatter data in the background
(Data > View Scatter Data on/off).

A useful tool to verify the arc definition is “redistribute vertices” :


Select an arc with



Select Redistribute Vertices in the pop up menu



A window showing information on the selected arc appears. Pay attention to the minimum segment
length that indicates the closest vertices within the arc. If this value is small you can either redistribute
vertices along the entire arc or manually delete or move the vertices that are close to each other.

and right click

It may help to do a few iterations of all the steps: generate the mesh, inspect the elements, delete the
mesh, apply some changes to vertices/arcs, re-generate the mesh, etc.
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To locate small elements within the mesh, and apply the necessary changes do the following:


Generate mesh



Go into Mesh editing mode : Mesh > Mesh Editing



Select : Mesh > Analyse mesh



This window will list the smallest elements, by clicking Zoom, the window will move to the
element.



Return to Mesh > Arc Editing and apply the necessary changes (delete/move/connect vertice or
node)
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When you are satisfied with your mesh, use the smoothing tool to readjust elements with small angles
(creates a more stable mesh)


Mesh -> Smooth Mesh



Then use interpolate Mesh and,



Finally export the mesh.

Adding new river links to the existing mesh that already has river links included
If you are importing additional links that weren’t included in the mesh previously, you will have to process the
*.xyz file exported from MIKE FLOOD. It is only necessary to import the newly created links and not the links
already part of the mesh.
The easiest way to achieve this is to:


Run MIKE FLOOD again with the new links and import the updated “river_curve.xyz” file to an empty *.mdf
file. This should show all the river links from MIKE FLOOD (cf.section 3.4.1)

Figure 3-8. New Mike Flood links imported into the Mesh Generator. Deletion of lateral links already included
in the mesh, keeping only the newly created links from the latest iteration of the model
development (here these are standard links added after the lateral links).


Select and delete the redundant link lines (in the example above we are only keeping additional
standard link lines)
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export the remaining arcs to a new *.xyz file: select all the arcs > Data > Export Boundary >
Selected Arcs and save the *.xyz file.


import in the mesh generator created previously.
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3.4.2

Other Forcing lines

3.4.2.1

Dike structures

Several linear structures such as roads and levees that have the potential to act as hydraulic controls, can be
added to the 2D domain using “dike” structures. Dikes in the model are polylines that control the flow through
specific geometry which can be sampled from the detailed LiDAR information. The location and crest levels of
these features were extracted from the LiDAR and overtopping is calculated in the model via weir equations.
In order to have accurate mapping as well as flow calculations along these structures it is recommended to
include them in the mesh via specific arcs. The latter will enforce the triangulation and help create an optimized
mesh.
Digitize location
of structures
• GIS
software
• *.shp
format

Define crest levels
in attributes
• Extract
crest levels
of
structures
from DEM
• or use
survey data

Figure 3-9

Import to Mesh
generator
• Convert
shapefiles
to *.xyz
files and
import as
boundaries

Generate mesh
and verify output
• Clean up
imported
arcs

Define "Dike" in
MIKE 21 FM
• Import xyz
file to
*.m21fm in
Dike
structures

Defining linear structures ("Dikes") process

The first step is to define the linear structures that will be defined as dikes with a GIS software.
Our spatial team here at Water Technology have developed a specific tool that allows to pick up the crest level
of these elements based on shapefiles and a DEM. This tool has been developed for the ESRI software
Arcmap. The advantage it offers is that is uses a search buffer along the shapefile to locate and extract the
highest point corresponding to the crest level of the structure and then move the vertice of the shapefile to that
point. This avoids the very time consuming, manual digitization of the exact crest of roads or levees.
In addition to the structures extracted from the LiDAR, survey data is available along Gunbower Creek from
previous studies. This information will be included in the mesh and the model via dike structures as well.
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The map below shows the location of the “dike” structures that will be included in the model.
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Figure 3-10 Location of Dikes structures to be included in the model (14/06/2017)
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The process to define the structure location within the Mesh Generator is similar to the process of excluding
1D branches. The lines are imported as boundaries. Therefore, the following step after digitizing the linear
structures is to convert the shapefiles (lines, with the crest level attribute) into *.xyz format. To do so, use the
Shp2xyz tool in the MikeZero Toolbox.

5151-01_R01v01f_GKP_FM.docx

The output file can then be imported into the mesh generator as a boundary. Repeat the steps listed in section
3.4.1. After cleaning up the data and making the necessary changes to the arcs, vertices, etc… the generated
mesh should look like this (using a maximum area of 80,000 m 2 , smallest allowable angle = 30)
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Figure 3-11 Mesh generated with 1D branches excluded and “dikes” imported (14/06/2017)
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After the location of “dike” structures to be included in the model has been defined in the mesh, it is necessary
to create these structures in the simulation file of the 2D model (*.m21fm)
As mentioned above, we have previously converted the shapefiles to *.xyz files that can be directly imported
into the 2D simulation editor. This is done by following the steps here-after:


Open the *.m21fm file and go to the structures menu and dikes



In the “list view” tab, create the number of dikes required



Click on “Go to…” and open the dike editor. The *.xyz file can be imported from the “Location and
geometry” tab. Specify the crest level as “varying in space”.



Specify the correct projection and browse for the *.xyz file that contains the dike coordinates and crest
level. The Coordinates and crest level should populate the table in the tabular section.



By clicking on “dikes” in the menu on the left of the window, the geographic view should appear, showing
the location of the dikes on the model domain.
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Note: they should be aligned with the mesh elements (we have previously enforced the lines in the
mesh generator).

Note that dikes can also be edited graphically in this window
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3.4.2.2

Other digitized elements

In addition to dike structures, some elements such as buildings or waterways can be forced upon the mesh to
improve the resolution, flood connectivity or mapping outputs of the model.
In the case of the GKP model it is necessary to define a certain number of waterways or flood runners within
the 2D flexible mesh to ensure the flow capacity, as well as the connectivity within the wetlands are well
described. This approach applies to waterways not represented by 1D branches, however this tool could also
be used to define new 1D branches within the floodplain.
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The following figure shows several offtakes on the Murray River (first few hundred meters) as well as Barbers
Creek that have been digitized and imported into the mesh.
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Figure 3-12 Digitized waterways (2D model) – 21/06/2017
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3.4.2.3

Mike Hydro Tracing tool

MIKE HYDRO allows to automatically trace waterways based on a delineation tool using a topographic dataset. This tool creates a 1D branch which we will convert to a shapefile and a *.xyz file that can be imported
into the mesh generator.


Open a new MIKE Hydro *.mhydro file and load a DEM. To speed up the process, a 10m resampled DEM
has been used (a *.dfs2 file can easily be resampled using the tool in MZtoolbox > Transformation >
Rotate grid)



In order to use the river tracing and catchment delineation on the map, the digital elevation data must be
preprocessed by clicking the button ‘Preprocess digital elevation data’. The DEM is preprocessed to create
a raster file with flow direction information that is used to delineate river branches and catchments.
After changing the spatial extent or resampling the elevation data, the DEM must be preprocessed again.
The processed data is saved in a ppdd-file. If no location is specified, then the ppdd file is saved by default
in the same location as the model setup.



When a DEM has been loaded the ‘Add Trace’ button is enabled on the Branch ribbon. Clicking on the
upstream location of the river will trace down to the outlet of the river based on the DEM data.
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To help locate the existing network you can load the shapefile of the 1D network (Map configuration
> Background layers)
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In the image below several flood runners have been digitized
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Once the tracing is done, export the branches to shapefile and convert them to *.xyz files that can imported
into the mesh.



The arcs can now be added to the mesh and improve the connectivity within the wetland areas through
better resolution where it matters.
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Flood runners
represented
in 2D, forced
into the mesh
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Figure 3-13 Flood runners tracing from MIKE HYDRO
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3.4.3

Polygons: optimizing resolution areas

The general cell size, or general maximum area used during the mesh generation is defined at the last step
before generating the mesh. Mesh -> Generate Mesh:

This value (maximum element area) will be applied to the entire domain except where local value will have
been defined. These local values are defined in the mesh generator via polygon markers within closed
polygons, formed by one or several arcs.

Select polygon

Insert polygon
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Once the polygon has been graphically placed on the mesh, the polygon selection tool allows to edit the
properties of the selected polygon (select -> right click ->properties).

By default, the inserted polygon will be set to exclude the area from the mesh (no elements generated within
the polygon area).
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In the properties menu, change the option to “Apply triangular mesh” then select “use local maximum area”.
This value will have to be smaller than the general Maximum Element Area, thus allowing the definition of
higher resolution areas within the domain.

3.5

Details on 1D/2D linking

MIKE Flood is a coupling software that dynamically links 1D and 2D components in a single model. The fluxes
are exchanged both ways via different links between the rivers (1D) and floodplains (2D).

3.5.1

Standard links

Standard links connect the end of a MIKE HYDRO branch to MIKE 21. Standard links are used to define the
transition from 1D flow to 2D flow.


MIKE HYDRO imposes a discharge in MIKE 21 (calculated as a source)



MIKE HYDRO requires a water level from MIKE 21

A standard link is defined with one chainage which must correspond to a water level boundary in MIKE HYDRO
with a cross section. The water level boundary in MIKE HYDRO is “dummy” and doesn’t affect MIKE FLOOD.
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When using a flexible mesh:


Linkage line mapped onto 1 or more element faces



Link works as a boundary condition in MIKE 21



Coupling line should be within the mesh



The predictor to estimate discharge in M11 is not used (≠rectangular grid)

Several parameters that are used for calculation through links are available in MIKE FLOOD. They are listed
below:


Momentum Factor: Value controlling whether the momentum exchange is to be included. Neglecting
momentum has a stabilizing effect on set-ups.


A value of 0: no momentum exchange



A value of 1: full momentum exchange

Murray-Darling Basin Authority | October 2017
Flexible Mesh Model Development

Page 44



Extrapolation Factor : Value controlling the forward estimation in time of M11 discharge at next time step.
Not applied when using flexible mesh.



Depth Adjustment: If selected the discharge is distributed according to the local water depth in M21 cells.
This is considered appropriate for links on natural terrain or channels. Higher discharge will be applied to
the cells with greater depth and conversely.



Exponential Smoothing Factor: It introduces an exponential smoothing of the water level values
transferred from M21 to M11


1 = no smoothing



0 = strong smoothing

Lowering this value has a stabilizing effect on set-ups.
The following section has been extracted from the MIKE FLOOD User Manual:
“The smaller the value the greater the smoothing will be. The parameter impacts the dynamics by
smoothing out steep gradients (in time) through the links.
In general, the exponential smoothing factor should be adjusted when a structure exhibits unstable
behaviour (oscillates wildly). The following approach should be followed if a link shows instability:
1. Set the exponential factor to 0.2 – 0.4
2. Run the model
3. If a link still “misbehaves”, (i.e causes a blow-up OR the discharge hydrograph is very 'noisy') then
check the results file, the model link location, the MIKE 21 topographic grid, the coupling, etc. for problems,
and inconsistencies.
4. Re-run the model if changes are made.
5. If the link still “misbehaves” then the smoothing factor may be further reduced. Note that a small
smoothing factor will cause a time lag in the transfer of the values from one model component to the other
model component.
6. Rerun the model.
7. If a small value of the smoothing factor is required, you need to satisfy yourself that the results are
reasonable and the results for the overall model have not been significantly delayed.”
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3.5.2

Lateral links

Lateral links allow linking between the banks of a river and the floodplain, to capture any overflow that may
occur, as described in Figure 3-14. In this section the lateral links set-up, calculations and options will be
discussed in detail.
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Figure 3-14 Lateral links between 1D and 2D models

1D water level calculation points are connected to 2D cells and water is exchanged between the channel and
the floodplain based on water levels in either domain. Therefore, flooding above banks and returning flows to
the river bed are dynamically calculated along the laterally linked branches. A distinction is made between the
right and left bank of the river, it is therefore important to accurately describe bank levels in at least one of the
two models (1D and 2D).
A lateral link is defined from an upstream to a downstream chainage. By default, the selection of cells in the
2D Grid is determined from the cross-section width (markers 1 and 3) and coordinates (if any).
Note: it is possible to use an external file, and/or graphically edit the links’ location afterwards.
The lateral link consists of many internal small structures/segments describing the levee (river bank). The
number of internal structures depends on whether there are more MIKE 21 grid cells in the link or MIKE
HYDRO grid points.
The flow is exchanged in MIKE HYDRO only at h-points - but at all coupled MIKE 21 cells/elements. The flow
is distributed according to chainage and distance along grid cell centres. Water levels are interpolated from
relative locations of 1D h-points and 2D cells, this interpolation is distance dependent and minimises
inconsistencies (in case the h-points are few and far apart and interpolated levels overlap).

5151-01_R01v01f_GKP_FM.docx

In the “Lateral Link Options” menu in MIKE FLOOD, several options are available under the “Structures”
section.
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Type refers to the type of flow calculation, where several weir equations or rating table can be
used to describe the flow;



The structure source determines where the levee height comes from:







M11: from bank markers of MIKE 11 cross-sections



M21: from cell or topography in MIKE 21



HGH: highest of MIKE 11 markers and MIKE 21 topography
Using HGH is recommended since it yields more stable calculations.



EXT: levee height supplied in external file as a function of chainage along levee

It should be noted that the source also determines the number of internal small structures within
the link:


M11: internal structures only located at MIKE 11 h-points locations



M21: internal structures only located at MIKE 21 cells’ locations



HGH: highest density of MIKE 11 and MIKE 21



EXT: internal structures located at chainages from the external file and from MIKE 11 hpoints

Depth Tolerance is used to dampen out oscillations when water level difference is small across
the link. A value of 0.1 m is recommended but may be increased in some cases
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The following points should be kept in mind while creating lateral links:


As mentioned above, water levels are interpolated along the lateral links between h-points for the 1D
component. However the levee height of the internal structure uses the closest h-point with a 1D cross
section marker (whether it’s an h-point at a cross section location or an interpolated h-point, cf. “max dx”
of the 1D branch). This value is not interpolated, therefore it is recommended that the number of cross
sections in the 1D model is sufficient to accurately describe the river banks.



At the start and end of the lateral links, the closest cross section within the range of start and ending
chainages will be used for the levee height in the 1D component. Cross section outside of the start and
ending chainages in the 1D will be ignored, even if closer.
This is illustrated in the Figure 3-15 below where the cross section at chainage 200 m will not be used in
the definition of the height of the levee. Indeed it is located outside of the start and ending chainages of
the link.
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Cross section not used
in link definition

Lateral link from 225m to 1500m

1D branch, from
0 to 1520m

Cross section
at chainage
1480m

Cross section
at chainage
200m

Cross section
at chainage
750m

Figure 3-15. Lateral link description

The number of h-points in the 1D model should also be carefully assessed to accurately describe sudden
changes in water levels, such as around weirs for example.
Ideally, an h-point for every cell would be perfect but not necessary nor practical in certain cases. As a
rule of thumb, a factor 5 between h-points and 2D cells is recommended.
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4

RESULTS

After several iterations of development and testing, the results presented below come from a coupled model
using a Mesh with approximately 170,000 nodes and 332,000 elements, and a 1D model containing 54
branches and 24 structures.
The performance of the GPU modelling with this resolution is as follows:
Table 4-1

Model run-time (version sent in September 2017)

Period of simulation

Calculation time

Run time (hr/hr)

1/09/2016 to 31/10/2010
(61 days)

5.76 days

10.6
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The widespread inundation of the GKP forests is well represented at this stage, with flood runners and their
connectivity well defined.
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Figure 4-1

Maximum depths (August-October 2016 event)
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The dynamics of the flooding of the area, in terms of extent and timing, will have to be compared to
observations in order to assess accuracy.
The results show numerical stability and the volume balance is good as shown in Table 4-2.
Table 4-2

Volume balance table

Volume in m3
A: Initial volume in model area

0

Final volume in wet area

159,541,575

Final volume in dry area

2,458

B: Final volume in model area
Source inflow
MIKE 11 inflow target
MIKE 11 inflow correction
Source outflow
MIKE 11 outflow target
MIKE 11 outflow correction
C: Total volume from source

159,544,033
0
2,108,813,031
-0.03
0
1,990,219,883
-40,950,886 (2%)
159,544,033
0

E: Total volume from boundaries

0

F: Continuity balance (B-A-C-D-E)

0
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D: Total volume from
precipitation/evaporation
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5

RECOMMENDATIONS

The model transferred to MDBA requires calibration and can be further developed to better represent the
dynamic behaviour of the GPK forests during flood events.
Water Technology suggest considering the following steps that could be taken to improve the modelling of the
GPK forests :


Calibration:


the use of different flood extents for various events should be compared to model results, as well as
flood levels if available. Based on the comparison results, MDBA could further optimise the mesh
resolution.



inclusion of a roughness map based on landuse could improve the model results across the
floodplains

Addition of 1D branches representing the flood runners in the floodplain and linking them to the 2D model.
In the current model the flood runners within the forests are represented in the 2D mesh, with smaller
elements to ensure connectivity. Laterally linked branches could possibly improve the representation of
the dynamic flooding through those intermittent waterways while reducing the number of small elements
in the mesh, thus reducing model run-time.



Linking Gunbower creek to the 2D model and including the potential exchange of flows through flooding
along this waterway. It appears that in certain areas the current model boundary blocks water and the
model could be extended further south to better represent flooding in the area.

5151-01_R01v01f_GKP_FM.docx



Murray-Darling Basin Authority | October 2017
Flexible Mesh Model Development

Page 52

Brisbane

15 Business Park Drive
Notting Hill VIC 3168
Telephone (03) 8526 0800
Fax
(03) 9558 9365

Level 3, 43 Peel Street
South Brisbane QLD 4101
Telephone (07) 3105 1460
Fax
(07) 3846 5144

Wangaratta

Perth

First Floor, 40 Rowan Street
Wangaratta VIC 3677
Telephone (03) 5721 2650

PO Box 362
Subiaco WA 6904
Telephone 0438 347 968

Geelong

Gippsland

PO Box 436
Geelong VIC 3220
Telephone 0458 015 664

154 Macleod Street
Bairnsdale VIC 3875
Telephone (03) 5152 5833

Wimmera

www.watertech.com.au

PO Box 584
Stawell VIC 3380
Telephone 0438 510 240

info@watertech.com.au

5151-01_R01v01f_GKP_FM.docx

Melbourne

Murray-Darling Basin Authority | October 2017
Flexible Mesh Model Development

Page 53

